Limitaciones de las fórmulas BUSCARV y BUSCARH

Primero debes completar BUSCARV antes de ver esta lección
Por favor compra el curso antes de comenzar esta lección.

Evitar los errores #N/A al no obtener coincidencias

Supongamos que queremos realizar lo siguiente: Queremos construir el balance agregado de cuatro empresas de un grupo, cada una de ellas con sus cuentas particulares, que aparecen en las hojas A, B, C y D y queremos que dicho balance aparezca en la hoja Agregada.

limitaciones-buscar
Presentamos cuatro tablas con distintos sumas y saldos.

Cada uno de estos balances tiene su propia estructura pero tienen en común que se muestran en grupos de tres dígitos, por lo que ayudándonos de la función “BUSCARV” vamos a llevar cada uno de los saldos a una hoja donde podremos agregarlos fácilmente:

Hemos agregados los cuatro sumas y saldos

Se observa que cuando una empresa no tiene definida la cuenta, al buscarla y no encontrarla la función BUSCARV() devuelve el error #N/A por lo que el agregado entonces da también error.

sumando-errores
Las fórmulas de error por los datos no encontrados impiden obtener el resultado de la suma.

Hay que tratar de evitar ahora este error. Para ello utilizaremos la función SI.ERROR(), que devuelve dos valores, o VERDADERO O FALSO. Así, en la celda C4 escribiremos:

=SI.ERROR(BUSCARV(A4;A!$A$2:$C$80;3;FALSO);0)

Esta fórmula devuelve el valor de la fórmula BUSCARV siempre que el valor de la misma no sea  error (en este caso, que no sea  #N/A). Si el valor de la fórmula toma un valor erróneo, la función SI.ERROR sustituirá el mismo por un valor nulo (que es el cero que hemos introducido en la sintaxis de la fórmula).

si-error
Utilizamos la fórmula SI.ERROR que ya vimos en el módulo de auditoria de fórmulas.

Lo mismo haremos en las columnas adyacentes para los valores del resto de los balances:

En la columna D:             =SI.ERROR(BUSCARV(A4;B!$A$6:$F$84;6;FALSO);0)

En la columna E:              =SI.ERROR(BUSCARV(A4;’C’!$A$6:$F$85;6;FALSO);0)

En la columna F:              =SI.ERROR(BUSCARV(A4;D!$A$2:$E$54;5;FALSO);0)

 

Descargar archivo adjunto
Podemos descargar el archivo Excel que hemos utilizado en esta lección desde el siguiente enlace:

 

Etiquetas de lecciones: buscarv, Excel, SI.ERROR
Volver a: Excel para Contables y Controllers > Las funciones BUSCARV y BUSCARH